
page 1               © Gilberto E. Urroz, Sept. 2009 

Introduction to the use of SMath Studio  
Prepared by Gilberto E. Urroz, September 2009 

 
Where to find SMath Studio? 
SMath Studio 0.85 is freeware that produces notebook type of mathematical calculations.   
You can download SMath Studio at  
http://en.smath.info/forum/default.aspx?g=posts&t=202  
 
Getting started 
You will find the icon for SMath Studio in the folder SMath\SMath Studio under your 
Program Files folder in your Windows machine, or under your Program Files (x86) 
folder if you have a 64-bit version of Windows.  The program is called 
SMathStudio_Desktop.exe.  You may want to create a shortcut to the program to place in 
your desktop or in your Quick Launch.  Double click on the program icon or on the 
shortcut to open the SMath Studio interface. 
 
The SMath Studio interface 
To get started, find the SMath Studio 
13 icon in your Start>Programs 
button in Windows.  The SMath 
Studio interface is shown here. 
 
The interface shows a main window 
with menus, a toolbar, and a number 
of palettes on the right-hand side of 
the interface.  The palettes contain 
mathematical, graphical, and 
programming functions that can be 
placed in the main window with the 
purpose of calculating mathematical 
expression, producing graphs, or 
building small programs.   
 
The SMath Studio menus 
The SMath Studio interface contains 
menus entitled File, Edit, View, 
Insert, Calculation, Tools, Pages, and 
Help.  Besides these 8 menus, there is 
also a menu indicated by a page icon 
located to the left of the menu bar.  
We'll refer to this menu as the Control menu.   Explore the different menus to become 
acquainted with the various options available in them.   The Control, File, and Edit 
menus operation is very similar to those of other Windows applications, therefore, the 
item therein contained would be familiar to Windows users.  Other menus are presented 
below. 
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The Help menu 
The Help menu contains the option Reference book… which represents a modest attempt 
by the author to address basic mathematical operations and definitions.  The contents of 
the Reference book are shown in the figure below.  To find the contents of a particular 
section of the Reference book, click on that section.  For example, to see the contents of 
the section entitled Limits, click on the corresponding link to produce the screen in the 
middle.  If you click on the link entitled Properties of limits, you get the screen shown to 
the right in the figure below.  This provides some basic properties of limits that can be 
useful to review that concept from Calculus.  
 

 
 
You can go back one page in the Reference book by pressing the option Back, or return to 
the Contents page by pressing the option Home.  The menu option Copy lets you copy 
equations from the Reference book that you can then paste in the main interface.  To copy 
a specific equation, first highlight the equation you want to copy.  We will illustrate this 
operation in another section of this document. 
 
The Help menu also contains the option Examples, which opens the following menu of 
examples: 

 
 
Click on a given example to select it, and press the [ Open ] button.   The worksheet 
corresponding to the example Numeric integration method (Simpson's rule) is shown 
below. 
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The Pages menu 
The Pages menu shows the pages (worksheets) currently 
open.  After having opened the worksheet for the 
example shown above, the Pages menu will show two 
pages open, namely, Page1,the default page open when 
we started SMath Studio, and Simpson.sm, the worksheet 
we just opened from the Examples menu. 
The Pages menu also shows the options New page and Close page, whose operation is 
obvious. 
 
The Tools menu 
The Tools menu has a single item (Options) which open the following dialogue form with 
two tabs.  The contents of the two tabs are shown below.   
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The Calculation tab in the Options interface lets you modify basic settings for 
mathematical calculations, whereas the Interface option deals with properties of the 
interface window.   
 
The Insert menu 
The Insert menu allows inserting a variety of items into the worksheet (or page), as 
indicated in the figure below: 
 

 
 
When you select the option Matrix.. produces an entry form that allows you build a 
matrix of a pre-determined size: 
 

 
 
The option Function… opens up a menu of mathematical functions, i.e.,  
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Selecting the option Operator… in the Insert menu produces a list of Boolean, arithmetic, 
and other operators, e.g.,  
 

 
 
The option Text region  in the Insert menu allows the user to insert text fields in the 
worksheet with the purpose of documentation.  This is equivalent to pressing the double 
quote (") after clicking in any position in the worksheet.  For example: 
 

 
 

Inserting a Separator simply means inserting a horizontal line to separate regions in the 
worksheet, e.g.,  
 

 
 
The insertion of plots and pictures will be illustrated in other sections of this document. 
 
The View menu 
The View menu includes a single option that lets you select or deselect the grid in the 
interface.  Here is the same worksheet with and without a grid: 
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The Calculation menu 
The Calculation menu offer options useful when calculating symbolic or numeric 
expressions.  Unless a particular calculation has been selected, these options show as 
inactive (shadow options) in the menu, e.g.,  
 

 
 
The only active options shown above are Auto calculation and Recalculate page.  The 
meaning of these, and the other options shown above, is obvious. 
 
The SMath Studio toolbar 
The SMath Studio toolbar contains 19 icons briefly described below: 
 

 
 

1. New page 
2. Open (existing worksheet) 
3. Save (current worksheet) 
4. Print (current worksheet) 
5. Cut 
6. Copy 
7. Paste 
8. Undo (recent action) 
9. Redo (recent action) 
10. Font size 

11. Text color 
12. Background color 
13. Align horizontally 
14. Align vertically 
15. Function 
16. Reference book (see Help) 
17. Recalculate page 
18. Interrupt process 
19. Show/hide side panel 

 
Items (1) through (4) manipulate new or existing worksheets.  Items (5) through (7) are 
editing functions.  Items (8) and (9) will un-do and re-do the most recent action.  Items 
(10) through (12) adjust font or background properties.  Items (13) and (14) re-align 
selected cells.  Item (15) opens the Function menu, as shown earlier.  Item (16) is also 
available under the Help menu. Items (17) and (18) were shown earlier in the Calculation 
menu.  Item (19) shows or hides the palettes on the right-hand side of the page.   
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Using SMath Studio as a calculator 
SMath Studio (or, simply, SMath) can be used as a calculator.  For example, open a new 
pate, and click on the main window in an area near the top left corner.  A small red cross 
will indicate the location where you want to enter a calculation. Type the following: 
 

1+2/3+4/5 = 
 
The result is the following expression: 
 

 
 

Notice the way that SMath interprets the two fractions.   Try the following example also: 
click somewhere else in your worksheet and type: 
 

5 + 2/3 []+ (4/5) = 
 
The result is now: 

 
 
 
Functions in SMath 
Calculations in SMath may involve mathematical functions such as sin, cos, exp, etc.  
You can insert any function by using the menu option Insert > Function… or by pressing 
item (15) [f(x)] in the toolbar.  As indicated earlier, collections of functions under the 
headings All, Matrix and vector, Complex numbers, Trigonometric, Hyperbolic, and 
Programming are available.   The figure below shows the options for complex number 
functions: 
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In this example, function arg is selected.  The argument (arg) of a complex number is the 
angle that a vector representing the complex number in the complex plane forms with the 
real (x) axis.  As indicated in the figure above, as you select a particular function the 
Insert – Function form provides an Example as well as a brief Description of the 
function.   
 
Typically, you will start an expression in the worksheet and, at the proper location, insert 
the function that you need.   For example, calculate the expression that uses the 
hyperbolic function asinh: 
 

 
 
Some functions are available for insertion in the Functions palette: 
 

 
 

To enter any of those functions simply place a cursor in the desired position and click on 
the name of the function, e.g., type: 

 
 
Some of the functions in the Functions palette include operations typical from Calculus, 
such as summation, products, derivatives, and integrals, e.g., 
 

 
 
In these expressions we used symbols that are available in the Functions palette as well 
as other symbols available elsewhere.  These are: 
 

 Infinity (∞) - available in the Arithmetic palette 
 Symbolic evaluation () – available in the Arithmetic  
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Numeric versus symbolic evaluation 
An expression that results in a number is evaluated using the numerical evaluation 
symbol (=), whereas, an expression that results in a symbolic output needs the symbolic 
evaluation symbol ().   Both symbols are available in the Arithmetic palette.  The 
numerical evaluation symbol (=) can be typed directly from the keyboard (it's just the 
equal sign).  The symbolic evaluation symbol () can also be entered by typing 
Ctrl+period (Ctrl+.). 
 
The examples above show the summation and product producing numeric results, while 
the derivative and the definite integral produce symbolic results.  Notice the difference 
between numeric and symbolic results in the following integral: 
 

 
 

The main difference between numeric and symbolic results in the current version of 
SMath Studio is on whether a result is shown in its decimal form (numeric) or as a 
fraction (symbolic) and other symbolic results such as square roots, etc.  A proper 
symbolic result in the integral above would have been the expression ln(3), however, 
SMath Studio does not handle such type of symbolic calculations when the result 
involves a function definition.  
 
For an open-source, free program that would handle such type of symbolic calculations 
please refer to this web site: http://www.neng.usu.edu/cee/faculty/gurro/Maxima.html. 
 
Note: Use function eval to convert from symbolic to numeric results, e.g., eval(sqrt(3)): 
 
 
An alternative for entering functions in expressions is simply to type the name of the 
function.   For example, click in another area of the main SMath Studio interface, and 
type the following expression: 
 

2.5*sin(2.5)+1.2*cos(2+3/(1+4*1.2^2)) 
 
The results of this operation will be shown as: 
 

 
 

The Insert - Function menu in SMath Studio 
As indicated earlier, the Insert - Function menu in SMath Studio can be obtained by 
pressing the [f(x)] button in the tool bar.  This menu includes function groups labeled All, 
Matrix and vector, Complex numbers, Trigonometric, Hyperbolic, and Programming.   
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The Complex numbers, Trigonometric, Hyperbolic, and Programming function groups 
include a relatively small number of easily recognizable functions.  The Matrix and 
vector group includes a total of 30 functions useful for the manipulation of and 
calculations with vectors and matrices.  As indicated before, examples and brief 
explanations of the functions are available in the Insert-Function menu.   
 
The All menu includes all existing functions in SMath Studio.  Herein we group some of 
those functions according to their applications: 
 

 Functions for input/output and file manipulation: dfile, rfile, wfile  
 Functions specific to SMath Studio: eval, range, sys  
 Functions for real numbers:  abs, exp, Gamma, ln, log, log10, mod, nthroot, 

numden, perc, round, sign, sqrt 
 Functions for algebraic manipulation: expand 
 Functions for solving equations: polyroots, solve 
 Functions for Calculus applications: diff, int, product, sum  
 Functions for interpolation: ainterp, cinterp, linterp 
 Statistics functions: random 

 
Note: Function expand actually produces factorization of algebraic expressions.  
Expansion of algebraic expressions is performed automatically in SMath Studio, e.g.,  
 
Entering Greek letter in SMath Studio 
Greek characters can be entered by using the Symbols palettes in the interface.  These 
palettes, showing lower-case and upper-case Greek letters, are shown in the figure below. 
 

 
 
An alternative way to enter Greek letters is to type a letter in the English alphabet 
followed by Ctrl-g.  This will generate a corresponding Greek letter.  For example, typing 
g Ctrl-g produces the Greek letter  (gamma).  The corresponding upper case character 
would be entered as G Ctrl-g, resulting in the letter  (upper-case gamma).   
 
The table below shows the letters of the Greek alphabet and its closest equivalent English 
letters. 
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Clicking on any of the letters in the Symbols palette will copy that letter to any entry 
point or text in the worksheet.  To illustrate this fact we perform symbolic and numeric 
calculations with trigonometric functions that features the value : 
 

 
 
Notice that SMath Studio assigns the proper value to the symbol in the calculation. 
 
Defining variables in SMath Studio 
To define a variable in SMath Studio use the assignment operator (:=).  To enter this 
operator simply press the colon key in your keyboard (:).  Click anywhere in the 
worksheet and make the following variable assignment:  x := 2, by typing: x : 2.  The 
value of 2 is now stored in the name x.  The value x = 2 will be replaced into any 
expression containing the name x that is located below or to the right of the assignment 
statement.  To check this fact, type an equal sign in a location above the assignment 
statement x:=2 and fill the placeholder to the left with the expression x2-3.  The result is 
inconclusive, as shown below.   Then, repeat this operation in a location below or to the 
right of the assignment statement x:=2.  The result now is 5, as illustrated below. 
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Once you have made variable assignments, you can use the assigned variables to 
calculate expressions.  As an example, assign the values x: =-2 and y:=3, then calculate 
the following expression: x2+y2.  The result may look somewhat like this: 
 

 
 
Documenting the worksheet 
In order to document your worksheet, you can add text to it by clicking on any place in 
the worksheet and typing ” followed by the text.  (Alternatively, you can use the option 
Insert>Text Region in the worksheet menu).  For example, the last exercise above, can be 
documented as follows: 
 

 

 
 
Selecting worksheet fields for editing and repositioning 
If you click on any of the text lines or the operations shown above, the corresponding 
field will be shown enclosed in a rectangle.  This indicates that the field can be edited for 
text or math calculations.  An example is shown below: 
 

 
 
A text or calculation field can also be selected by clicking in a region near the field and 
dragging the mouse towards the field.   In this case, the field is enclosed by a frame with 
blue boundaries and a blue background, e.g.,   
 

 
 

When selected in this way, a field can be dragged and positioned somewhere else in the 
worksheet.  For example, the result shown above could be re-organized as follows: 
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A field selected by dragging can be erased from the worksheet by pressing the [delete] or 
the [backspace] key.   The selected field can also be copied and pasted by using Ctrl-C  
and Ctrl-V, respectively.  By dragging on top of two or more fields, multiple fields can be 
selected simultaneously for editing. 
 
Horizontal and vertical alignment of cells 
Items (13) and (14) in the SMath Studio toolbar (see figure below) provide for horizontal 
and vertical alignment of cells in the worksheet. 
 

 
 
Consider the following text and calculation cells that are misaligned horizontally: 
 

 
 
The four cells were selected by dragging the mouse, while holding the left button, over 
the cells.  Next, press button (13) in the toolbar to get the following result: 
 

 
 
Now, for an exercise on vertical alignment, consider the following vertically misaligned 
cells: 
 

 
 

 
After pressing button (14) in the toolbar we get the following result: 
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Adding images to the worksheet 
Images scanned into the computer or produced by other graphic software can be 
incorporated into your worksheet in different ways.   
 
1 – Copying a figure from other software, clicking and using Paste (or Ctrl-v). 
2 – Using Insert > Picture > From file …, to insert a picture contained in a file. 
3 – Using Insert > Picture > Create …, to insert a picture frame where you can draw 
your own picture.  Use the mouse as a pencil.  SMath Studio  does not provide for other 
drawing tools 
 
Examples of the three cases are illustrated below.  The only images allowed to insert 
from a file are bitmap images.  Through the cut-and-paste procedure, you can paste 
images from any format. 
 

 
 
With text and calculation cells, plus image cells imported into or created within SMath 
Studio, you can produce technical reports as would be required for class assignments or 
for an engineering project.   
 
Application – Writing an assignment in SMath Studio 
The figure in next page shows a class assignment in fluid mechanics/hydraulics prepared 
in SMath Studio. 
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If you prefer, you can click off the grid using the View menu to produce the following: 
 

 
 

 
Notes:   
(1)  To enter multiple lines in a text box, use Shift-Enter at the end of each line. 
(2) SMath Studio doesn't yet have the ability to handle units.  The units you see in these 
examples were inserted as text fields.   
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User-defined functions 
You can define your own functions by using the expression  
 

function_name(argument(s)): function_expression 
 
Examples of definitions and evaluations of functions are shown below: 
 

 
 

Plots of functions in 2D 
SMath Studio allows the user to insert two-dimensional (2D) plots by using the 2D option 
in the Plot palette, or the menu option Insert > Plot > 2D.  This action will open a 2-D 
graph window, as illustrated below: 
 

 
 
In the place holder on the lower left corner of the graph window you can enter the name 
of a function to plot, e.g.,  
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If you click on the graph window, you can drag one of the window handles shown below 
(right-hand side, bottom, or lower right corner) to modify the size of the window.  
 

 
 
Some resizing examples are illustrated below: 
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Plotting more than one function 
To plot one than one function, use the Equation systems option in the Functions palette, 
namely, 

, 
 
to insert more than one function in the function placeholder for the graph window.  Here 
is an example: 
 

 
 
 
Plots of functions in 3D 
Use the 3D option in the Plots palette, or the 
menu option Insert > Plots > 3D.   Type the 
equation f(x,y) in the place holder located in 
the lower left corner of the graph window.  
You can drag the mouse pointer in the graph 
window to rotate the graph for a better view 
of the mesh surface, as illustrated here: 
 
Resizing of the graph is also possible as done 
for 2D graphs. 

 
 
 
As we did with 2D plots, you can plot 
more than one 3D plot as illustrated in 
the graph to the left. 
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Additional manipulation of graphs 
Additional manipulation of graphs is possible using the Plot 
palette.  The Plot palette includes the following buttons: 
 

(1) Rotate – for 3D graphs, default setting  
(2) Scale – With  Ctrl or Shift, while dragging mouse over the graph, for proportional 

scaling – play around with this command to understand its operation 
(3) Move – move the graph around in existing graph window 
(4) Graph by points – show graph made of discrete points 
(5) Graph by lines – show graphs made of continuous lines 
(6) Refresh – refresh graph window to its default settings 

 
Try these options on your own to learn more about the different Plot palette actions.  The 
example below shows a proportional scaling using item (3) above, while holding down 
the Shift key. 
 

 
 
Plotting your own functions 
Define a function as indicated earlier, and replace the function name in the graph window 
place holder.  Here is an example: 
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Defining functions with the if function 
Some functions require more than one expression for their definition.  For example, 
 






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2,1
)( 2 xx

xx
xF . 

 
This function can be defined using the if function in the 
Programming palette.  When selecting this option, the 
following programming structure, with placeholders, is 
produced: 

 
   
              To program the function  
              shown above, we can use:   
 

 
If the definition of the function requires more than two expressions, it will be necessary 
to use nested if programming structures. Consider the following example: 
 
Function defined as:                                                     Function programmed as: 
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A plot of this function is shown below: 
 

  
 
More details on programming in SMath Suite will be provided in a later section. 
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Functions defined by calculus operations 
The Functions palette include four operations that are proper from calculus: summation, 
product, derivative, and integrals.  These functions can be incorporated in the definition 
of functions as illustrated in the following examples: 
 

 
 
Notice that the functions f(x) and g(x), whose argument defines the upper limit of the 
summation and product, are only defined for integer values.   
 
Solving single equations with solve 
Function solve can be used to solve single equations.  The function can be called using 
either of the following calls: 

solve(equation, variable) 
or 

solve(equation, variable, lower limit, upper limit) 
 
Examples using both symbolic and numeric results are shown below: 
 

 
 

Function solve provides only real roots.  Polynomial equations can be solved using 
polyroots, as described below.  
 
Note: to enter the Boolean equal sign (bold =) use 
Ctrl+=, or the symbol in the Boolean palette. 
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Application:  Solving for the flow depth in an open channel flow  
The following example shows how to use function solve to calculate the normal depth of 
flow in an open channel flow of circular cross-section.  The problem statement and 
solution commentaries were all entered using SMath Studio.  Also, a figure was created 
using Window's Paint and pasted into the SMath Studio worksheet. 
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Changing the number of decimals in the output 
Most of the numeric calculations and equation solutions shown so far in this document 
use four decimals (default value).  Using the Tools > Options menu item you can change 
the number of decimals in the output.  For example, changing to 15 decimals for output, 
we solve the equation presented above to obtain the following results: 

 
 
 
 
 

 
 
 
 
For the rest of the examples in this document we 
will use the default number of decimal figures, 
i.e., 4 decimals. 
 

 
Solving polynomial equations with polyroots 
Function polyroots returns the roots of a polynomial using as argument a column vector 
with the polynomial coefficients.  The coefficients must be entered in the vector in 
increasing order of the power of the independent variable.  For example, the vector 
corresponding to the polynomial 1 + 2x - 5x2   is: 
 




















5

2

1

v . 

 
Using SMath Studio, the roots of this polynomial are calculated as follows: 
 

 
 
To enter a column vector, a row vector, or a matrix, use the first 
icon in the Matrices palette.  This icon opens a dialogue box 
where the user can select the number of rows and columns for 
defining a vector or matrix.  By default, the dialogue box uses a 3×3 matrix.  For the 
column vector v, shown above, we used, of course, 3 rows and 1 column: 
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Unlike function solve, which provides only real functions, function polyroots provides 
either real or complex roots, or both.  For example: 
 

 
 
Application: Solving homogeneous, linear, constant-coefficients ODEs  
A n-th order, homogeneous, linear ordinary differential equation (ODE) with constant 
coefficients is represented by the expression: 
 

 
 
Introducing the notation Dn = dn( )/dtn, the general n-th order equation can be written as: 
 

. 
This expression can be “factored” in terms of the D operators to read: 
 

 
 
If we take the expression between parentheses and replace the D operators with the 
variable  and make it equal to zero, we would have produced the so-called 
characteristic equation of the ODE, i.e.,  
 

 
 
There are, in principle, n solutions of this polynomial equation, namely, 1, 2, ..., n. 

Some of these solutions could be complex (or imaginary), or even repeated. In the case 
that all solutions are real and non-repeating, the general solution to the original 
homogeneous ODE is given by: 
 

. 
 
If a root m, repeats k times, it will result in k terms in the solution given by  
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page 25               © Gilberto E. Urroz, Sept. 2009 

If there are complex roots, they will be an even number of them, i.e., pairs of complex 
conjugates.   Thus, if one of those pairs of complex conjugate roots is 1 =  +  i and 2 
=  -  i, then the following terms will appear in the solution: 
 

)sin()cos( 21 teAteA tt     
 

Function polyroots can be used to solve the characteristic equation, or characteristic 
polynomial, for an n-th order, homogeneous, linear ODE.  The roots of the characteristic 
polynomial can then be used to build the solution.  One example is shown below. 
 

 
 
The calculation of derivatives is all performed using symbolic calculations, and the 
results are very long.  Also, the current version of SMath Studio (version 0.85, 09/2009) 
doesn't simplify results and keeps the value exp(0) instead of 1.  Helping SMath Studio 
with these shortcomings, and with a lot of patience, you can get to put together the 
system of linear equations needed to solve for the coefficients A1, A2, and A3, in the 
solution to this ODE. (The figure below shows only parts of some calculations). 
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The resulting equations can be summarized as follows: 
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And, since we are dealing with matrices already, we introduce their use in SMath Studio 
next. 
 
Operations with matrices 
The functions available under the Insert > Function menu under the heading Matrix and 
vector can be roughly classified into the following categories: 
 

 Creating matrices: augment, diag, identity, mat, matrix, stack 
 Extracting rows, columns, elements: col, el, row, submatrix, vminor, minor 
 Characterizing matrices: cols, det, length, max, min, norm1, norme, normi, rank, rows, tr 

 Sorting functions: csort, reverse, rsort, sort 
 Matrix operations: alg, invert, transpose 

 
Some of these functions are also available in the Matrices 
palette: 
 
  (1) Matrix 3x3 (Ctrl+M) (mat) 
  (2) Determinant (det)  
  (3) Matrix transpose (Ctrl+1) (transpose) 
  (4) Algebraic addition to matrix (alg) 
  (5) Minor (minor) 
  (6) Cross product 
 
The only function from the Matrices palette not available from the Insert > Function > 
Matrix and vector functions is (6) Cross product, which applies to two vectors of three 
elements.     
 
It is important to indicate that even though you can form row vectors, many of the matrix 
and vector functions defined in SMath Studio apply only to column vectors.  Thus, 
column vectors are considered true vectors for the purpose of matrix operations in SMath 
Studio.   For example, to calculate a cross-product you will need two column vectors of 
three elements.  Dot products, on the other hand, can be performed on column vectors of 
any length.  The dot product of two column vectors is calculated as the matrix product of 
the transpose of one of the vectors times the second vector.  Examples of matrix and 
vector operations follow.  The vector and matrix names used in the examples suggest the 
dimensions of the vector or matrix.  For example, u2x1 suggest the vector u2×1, and A3x3 
suggests the matrix A3×3. 
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Examples of matrix creation: 
 
 
 

 
 
 
Examples of extracting rows, columns, or elements from matrices: 
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Examples of matrix characterization: 
 
 
 

 
 
 
 
Examples of matrix/vector sorting functions:   
 
 
 

' 
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Examples of matrix operations: 
 

 
 
Examples of vector products: 
 

 
 

Ranges and vectors 
Function range is used to generate a vector (column vector) with elements equally 
spaced.  The general form of the range function is as follows: 
 

 range(start, end): shows up in the worksheet as start..end, and produces a vector 
whose elements are start, start + 1, start + 2, etc.  The last element is the lowest 
value smaller than last by less than one.  

 range(start, end, start+increment): shows up in the worksheet as start, 
start+increment .. end, and produces a vectors whose elements are start, start + 
increment, start + 2 increment, etc.  The last element is the lowest value smaller 
than end by less than increment.   
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The following examples illustrate the use of function range.  The examples are numbered 
1 through 7.  Immediately below the Example number the range function call that 
produces the range is shown.  For instance, in Example 1, typing the expression 
range(0,10) produces the range 0..10, assigned to k.   
 

 
 

 Example 1 shows a vector from 0  to 10 with default increment of 1. 
 Example 2 shows a vector from 0 to 20  with increment of 2. 
 Example 3 shows a vector from 1.2 to 4.4 with default increment of 1. 

 
 

 
 
 

 Example 4 shows an impossibility since the value of start + increment < start, but 
end > start 

 Example 5 shows a vector from 1.2 to 4.4 in increments of 2 
 Example 6 shows a vector from 0.5 to 5 in increments of 0.5 
 Example 7 shows a vector from 10 down to 1 in negative increments of -1 
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Vectors can be combined linearly to produce other vectors, as illustrated here: 
 

 
 
The following examples illustrate three different ways to calculate products of vectors of 
the same lengths:  
 

1. Product of the vectors produces the scalar (dot) product 
2. Product of a vector transpose with another vector produces the same scalar (dot) 

product as the only element of a 1×1 matrix 
3. Product of a vector with the transpose of another vector produces a matrix 

 

 
 
Individual elements of a vector can be extracted by using the name of the 
vector with a sub-index.  To enter a sub-index, type the name of the vector 
and press the left square bracket key ([).  Press the right arrow key [] a 
couple of times to select the indexed variable.  Examples: 
 
Vectors of the same length can be put together in a matrix through function augment: 
 

 
 
This can be used to build tables of data. 
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for loops and parametric plots 
A parametric plot is defined by points (x(t), y(t)), where t  is referred to as the parameter.   
In this example we generate data (x,y) and (y,x) using for loops, and plotting the resulting 
matrices. 
 

 
 
Commands in the Programming palette 
The Programming palette includes four commands, namely, if, 
while, for, and line.  We have presented examples of the 
commands if, for, and line, in this document.  Here is an 
example of the while command: 
 

  
 


