Introduction

The Peng-Robinson equation of state (Ding-Yu Peng and Donald B. Robinson, "A New Two-Constant Equation of State", Ind. Eng. Chem. Fundam., Vol. 15, No. 1, pp. 59-64,1976) is widely used for calculating the thermodynamic properties of both pure fluids and fluid mixtures. Although not as accurate the Fundamental Equation of State formulations used in most of the EES pure fluid property data base, the Peng-Robinson equation offers algebraic simplicity and generality since is requires minimal data. Only the critical temperature and pressure and the acentric factor are needed to determine the properties for a pure fluid. Binary interaction parameters are needed in addition to determine the properties of a mixture. The Peng-Robinson equation of state is claimed to provide reasonably accurate estimates of liquid as well as vapor phase densities. As a result, the Peng-Robinson equation can be used to determine the vapor pressure of pure fluids. With known binary interaction parameters, the Peng-Robinson equation can be used to do multi-component liquid-vapor phase equilibrium calculations.

The Peng-Robinson equation is:

where

P is the pressure

T is the absolute temperature

v is specific volume

a(T) is a fluid-specific constant that depends on temperature

b is a fluid-specific constant.

The Peng-Robinson equation can be written in terms of the dimensionless compressibility factor as:

where

Procedures AB_PR and AB_MIX_PR determine the values of these parameters for pure fluids and mixtures, respectively.

Note the equation for Z is cubic. In general, the solution of this equation can have one or three real roots. Only one root exists if the fluid is above the critical point. When two phases coexist, two of the three possible roots correspond to saturated liquid and vapor, respectively, while the third root is a numerical aberration and has no physical meaning. Functions Z_G_PR and Z_L_PR have been developed to return the roots of the equation. If there is only one root, both functions will return the same value, but if there are two phases, Z_L_PR will return the compressibility for the liquid phase (the smallest non-zero root) and Z_G_PR will return the compressibility for the vapor phase (the largest root). Note that for temperatures below the critical temperature, the compressibility factors returned by Z_L_PR and Z_G_PR may differ, but this alone does not indicate a two-phase system.

The Peng-Robinson equation of state can be used to determine the enthalpy and entropy of a fluid or fluid mixture provided that the specific heat of the pure fluid(s) in the ideal gas state is known as a function of temperature. If the fluid obeyed the ideal gas law, then that is all of the information that would be needed to calculate the enthalpy and enthalpy relative to a selected reference state. When the fluid does not obey the ideal law, additional terms must be included in the enthalpy and entropy functions. These terms are most conveniently presented in terms of the enthalpy and entropy departures which are provided in functions H_DEP_PR and S_DEP_PR. When calculating the departure functions for a mixture, it is necessary to numerically evaluate da/dT. Function DSADT_MIX_PR provides this service.

A criterion of phase equilibrium for a pure fluid is that the fugacity of the liquid must be equal to the fugacity of the vapor. The ratio of the pure component fugacity to pressure is called the fugacity coefficient. The fugacity coefficient for a pure fluid is returned using the Peng-Robinson equation of state in function PHI_PR.

The fugacity concept can be extended to mixture by defining the partial fugacity coefficient as the ratio of the partial fugacity to the product of the mole fraction and pressure for the fluid component. At equilibrium, the partial fugacity of each component in the liquid phase must equal its partial fugacity in the vapor phase. Function PHI_I_PR returns the partial fugacity of one component in one phase of a mixture.

The solution to a phase equilibrium problem, though simple in concept, is mathematically difficult. The solution is necessarily numerical and iterative and a poor guess will result in an attempt to take the log of a negative value. Consequently, good guess values for the unknown quantities are required for a successful calculation.

The functions and procedure composing the Peng_Robinson library are listed below. Click on the name for more information.

AB_PR(Tr, Pr, w: A, B)

AB_MIX_PR(N, X[1..N], A[1..N], B[1..N], k_12, k_13, .. k_23,.. : A, B)

Z_G_PR(A, B)

Z_L_PR(A, B)

H_Dep_PR(Tr, w, Z, B)

S_Dep_PR(Tr, w, Z, B)

PHI_PR(Z, A, B)

PHI_I_PR(Z, A, B)

DSADT_MIX_PR(N, T, Tc[1..N], Pc[1..N], w[1..N], X[1..N], k_12, k_13, .. k_23, ..)


AB_PR

Procedure AB_PR returns the constants A and B for a pure fluid used in the Peng_Robinson equation of state. The procedure definition is:

Procedure AB_PR(Tr, Pr, w : A, B)

where

Tr is the reduced temperature (ratio of absolute temperature to critical temperature)

Pr is the reduced pressure (ratio of absolute pressure to critical pressre

w is the acentric factor

Use the Call keyword to access procedure AB_PR from EES.

Example:

Tr=0.85

Pr=0.5

omega=0.05

Call AB_PR(Tr, Pr, omega: A,B)

{Solution:

A=0.3391

B=0.04576

omega=0.05

Pr=0.5

Tr=0.85

}


AB_MIX_PR

Procedure AB_MIX_PR returns the Peng-Robinson constants A and B for a a mixture of two or more (up to 10) fluids. The procedure definition is

Procedure AB_MIX_PR(N, y[1..N], A[1..N], B[1..N], k[1..N,1..N]: A, B)

where

N is the number of fluids forming the mixture. N must be between 2 and 10

y[1..N] is an array of mole fractions of the N components in the mixture.

A[1..N] is an array of N values corresponding to the A parameters for each of the N pure fluids. These values are provided by AB_PR.

B[1..N] is an array of N values corresponding to the B parameters for each of the N pure fluids. These values are provided by AB_PR.

k[1..N,1..N] is the binary interaction matrix. Note that k[i,i] should be 0 and k[i,j] should be equal to k[j,i].

Note that the sum of the mole fraction should be 1.0 and y here could refer to the composition of the liquid or vapor phase.

The binary interaction matrix must be supplied even if all values are 0.

Use the Call keyword to access procedure AB_MIX_PR from EES.

Example:

Call AB_MIX_PR(2, X[1..2], A[1..2], B[1..2], k[1..2,1..2] : A, B)


Acentric Factor

The acentric factor, w, is defined as:


Z_G_PR and Z_L_PR

Z_G_PR(A,B) and Z_L_PR(A,B) both return the compressibility, Z, of the fluid according to the Peng-Robinson equation of state. The compressibility is the ratio of the specific volume of the gas to the specific volume of an ideal gas at the same temperature and pressure. The values A and B can be for a pure fluid (found from Procedure AB_PR) or a mixture (from Procedure AB_MIX_PR)

Note the the equation for Z is cubic. In general, the solution of this equation can have one or three real roots. Only one root is exists if the fluid is a single phase. When two phases coexist, two of the three possible roots correspond to saturated liquid and vapor, respectively, while the third root is a numerical aberation and has no physical meaning. If there is only one root, both functions will return the same value, but if there are two phases, Z_L_PR will return the compressibility for the liquid phase (i.e., the smaller value) and Z_G_PR will return the compressibility for the vapor phase (i.e., the larger value).

Example:

Tr=0.85

Pr=0.5

omega=0.05

Call AB_PR(Tr, Pr, omega: A,B)

Z_L=Z_L_PR(A,B)

Z_G=Z_G_PR(A,B)

{Solution:

A=0.3391

B=0.04576

omega=0.05

Pr=0.5

Tr=0.85

Z_G=0.5748

Z_L=0.07656

}


H_DEP_PR

H_DEP_PR (Tr, w, Z, B) returns the dimensionless enthalpy departure of a pure fluid according to the Peng-Robinson equation of state

where

Tr is reduced temperature

w is the acentric factor

Z is the compressibility factor

B is the second Peng-Robinson equation of state parameter

The dimensionless enthalpy departure is the difference in enthalpy between an ideal gas (designated with a superscript 0) and a real gas at the same temperature and pressure divided by (R Tc) where R is the gas constant and Tc is the critical temperature.

Note that Z is provided by functions Z_G_PR and Z_L_PR and B is provided by procedure AB_PR for pure fluids.

The enthalpy departure of a mixture cannot be determined with this function since Tr for a mixture is not defined. Using the Peng-Robinson equation for a mixture, the enthalpy departure for a mixture can be expressed:

Procedure AB_MIX_PR can be used to determine values of A and B for the mixture and functions Z_G_PR and Z_L_PR provide the value of Z for the mixture. The value of da/dT for the mixture is provided by function DSADT_MIX_PR.

Example:

Tr=0.85

Pr=0.5

omega=0.05

Call AB_PR(Tr, Pr, omega: A,B)

Z_G=Z_G_PR(A,B)

R=R#

Tc=190.6 [K] "methane"

DELTAh=H_DEP_PR(Tr,omega,Z_G,B)*R*Tc

{Solution:

A=0.3391

B=0.04576

DELTAh=1608 [kJ/kmol]

omega=0.05

Pr=0.5

R=8.314 [kJ/kmol-K]

Tc=190.6 [K]

Tr=0.85

Z_G=0.5748

}


S_DEP_PR

S_DEP_PR (Tr, w, Z, B) returns the entropy departure for a pure fluid according to the Peng-Robinson equation of state

where

Tr is reduced temperature

w is the acentric factor

Z is the compressibility factor

B is the second Peng-Robinson equation of state parameter

Entropy departure is the difference in entropy for an ideal gas (designated with the superscript 0) and a real gas at the same temperature and pressure divided by R, the gas constant.

Note that Z is provided by functions Z_G_PR and Z_L_PR and B is provided by procedure AB_PR for pure fluids.

The entropy departure of a mixture cannot be determined with this function since Tr for a mixture is not defined. Using the Peng-Robinson equation for a mixture, the entropy departure for a mixture can be expressed:

Procedure AB_MIX_PR can be used to determine values of A and B for the mixture and functions Z_G_PR and Z_L_PR provide the value of Z. The value of da/dT for the mixture is provided by function DSADT_MIX_PR.

Example:

Tr=0.85

Pr=0.5

omega=0.05

Call AB_PR(Tr, Pr, omega: A,B)

Z_G=Z_G_PR(A,B)

R=R#

Tc=190.6 [K] "methane"

DELTAh=H_DEP_PR(Tr,omega,Z_G,B)*R*Tc

DELTAs=S_DEP_PR(Tr,omega,Z_G,B)*R

{Solution:

A=0.3391

B=0.04576

DELTAh=1608 [kJ/kmol]

DELTAs=7.126 [kJ/kmol-K]

omega=0.05

Pr=0.5

R=8.314 [kJ/kmol-K]

Tc=190.6 [K]

Tr=0.85

Z_G=0.5748

}


PHI_PR

PHI_PR(Z, A, B) returns the fugacity coefficient (ratio of fugacity to pressure) for a pure fluid or for a entire mixture that obeys the Peng-Robinson equation of state. Use function PHI_I_PR to determine the partial fugacity coefficient for a component in a mixture.

Note that Z is determined by functions Z_G_PR and Z_L_PR and A and B are provided by procedure AB_PR and AB_MIX_PR for pure fluids and mixtures, respectively.

Example:

Tr=0.85

Pr=0.5

omega=0.05

Call AB_PR(Tr, Pr, omega: A,B)

Z_G=Z_G_PR(A,B)

phi=PHI_PR(Z_G,A,B)

{Solution:

A=0.3391

B=0.04576

omega=0.05

phi=0.714

Pr=0.5

R=8.314 [kJ/kmol-K]

Tr=0.85

Z_G=0.5748}


PHI_I_PR

PHI_I_PR(N, i, Z, y[1..N], A[1..N], B[1..N], k[1..N,1..N]) returns the partial fugacity coefficient (ratio of partial fugacity to product of mole fraction and pressure) component i in a mixture according to the Peng-Robinson equation of state. Use function PHI_PR to determine the fugacity coefficient for a pure fluid.

The parameters in this function are:

N is the number of fluids in the mixture where N is between 2 and 10

i is the number of the component for which the partial fugacity is to be evaluated

Z is the compressibility for the liquid or vapor phase for which the partial fugacity is to be evaluated

y[1..N] is an array of N values that are the mole fractions of the N components for the liquid or vapor phase. Note that the sum of the mole fraction should be 1.0.

A[1..N] is an array of N values corresponding to the A parameters for each of the N pure fluids. These values are provided by AB_PR.

B[1..N] is an array of N values corresponding to the B parameters for each of the N pure fluids. These values are provided by AB_PR.

k[1..N,1..N] is the binary interaction matrix. Note that k[i,i] should be 0 and k[i,j] should be equal to k[j,i].

Note that Z is determined by functions Z_G_PR and Z_L_PR and A[1..N] and B[1..N] are provided by procedure AB_PR for each of the N pure fluids.


DSADT_MIX_PR

The enthalpy departure of a fluid that obeys the Peng-Robinson equation of state can be expressed:

The entropy departure is:

For a pure fluid, the dimensionless enthaply and entropy departures areprovided by functions H_DEP_PR and S_DEP_PR., respectively. For a mixture, a and b can be obtained directly from A and B which are provided by AB_MIX_PR since

However, it is necessary to evaluate da/dT. This function provides this service. The function is called with the following parameters:

DSADT_MIX_PR(n, T, Tc[1..n], Pc[1..n], w[1..n], y[1..n], k_12, k_13, ...)

where

n is the number of fluids in the mixture

Tc is an n-dimensional array with the critical temperatures of each of the fluids

Pc is an n-dimensional array with the critical pressures of each of the fluids

w is an n-dimensional array with the acentric factors of each of the fluids

y is an n-dimenionsal array with the mole fractions of each of the fluids

k_12 is the interaction coefficient between fluid 1 and 2. k_13 is the binary interaction component between component 1 and 3 and so on. The number of binary interaction coefficients that must be provided is in general:

Binary interaction coefficient values must be supplied even if their values are 0.

NOTE: The value returned the DSADT_MIX_PR has units of Pa-m^6/kmol^2-K. This is the only function in the Peng-Robinson library that is not dimensionless.